Z900RS

Please login or register.

News: A big welcome to all new members !



Author [NL] [FR] [ES] [DE] [SE] [IT] [NO] [MY] Topic: red warning light on  (Read 2121 times)

0 Members and 1 Guest are viewing this topic.

Offline joe

  • Z900RS Member
  • **
  • Posts: 10
  • Bike: 2018 z900 RS
  • Town / City: vancouver island
  • Country: ca
Re: red warning light on
« Reply #20 on: June 11, 2019, 10:19:03 PM »
well, it happened again.After sitting for three days after a 2800km beautiful trip.When i started it the red light stayed on until i replaced the k & n filter that i put on before i left.Another k&n and the light went out in 2 sec.What's happening? Is the sensor gone funny?
thanks

Offline IndyTom

  • Z900RS Pro
  • ***
  • Posts: 422
  • Bike: 2018 Z900RS
  • Town / City: Noblesville
  • Country: us
Re: red warning light on
« Reply #21 on: June 11, 2019, 11:06:42 PM »
My guess it is a faulty oil pressure sensor.   Happened to my brand new bike a couple of years ago.  The Red light came on and stayed on while I was on the way back from the dealer.  I stopped and called them.  They picked it up and took it back to the shop.   They tested the sensor and sure enough it was a bad sensor.   They replaced the sensor and delivered the bike to me.   Never had an issue after that.   
I would take it to the dealer and have them check it just to be sure.  If it isn't the sensor than it could be something more serious and you don't want to ride around with low or no oil pressure.
I don't usually have a big smile on my face, but when I do I probably am riding my bike.